Gestión de permisos en Android


#1

Hola… Estoy haciendo mi primera app con Framework7, el problema que tengo es que al instalar la app en equipos Android 6.0 y superiores no pide las autorizaciones requeridas al momento de querer usar la opción.

Utilizo cordova Versión 8, Framework7 2.0.8 y leaflet 1.3.1, y requiero hacer unas pruebas de geolocalización utilizando Open Street Maps.

El archivo config.xml es

<?xml version='1.0' encoding='utf-8'?> ITrust A sample Apache Cordova application that responds to the deviceready event. Apache Cordova Team

No he podido aclarar asuntos de versiones y principalmente el manejo de permisos para Android 6.0 y superiores… Les agradezco me puedan ayudar con este tema …Saludos…


#2

Hola! He visto tambien que has comentado en mi blog, responderé en los dos, lo que necesitas es este plugin el cual se encarga de pedir los permisos al usuario, te dejo en enlace por aqui donde explican su uso, si tienes cualquier problema comenta aqui y lo vemos.

Saludos