[SOLVED] Framework7-Vue-Webpack build error


#1

Good afternoon! Faced such a problem when starting Framework7-Vue-Webpack… Maybe someone had such errors?

ERROR Failed to compile with 10 errors16:53:53

These dependencies were not found:

* !../..!Catopes2/node_modules/vue-loader/lib/component-normalizer in ./src/app.vue
* !!../..!Catopes2/node_modules/vue-loader/lib/template-compiler/index?{"id":"data-v-5ef48958","hasScoped":false,"transformToRequire":{"video":["src","poster"],"source":"src","img":"src","image":"xlink:href"},"buble":{"transforms":{}}}!../..!Catopes2/node_modules/vue-loader/lib/selector?type=template&index=0!../..!Catopes2/src/app.vue in ./src/app.vue
* !!babel-loader!../..!Catopes2/node_modules/vue-loader/lib/selector?type=script&index=0!../..!Catopes2/src/app.vue in ./src/app.vue
* !../../..!Catopes2/node_modules/vue-style-loader/lib/addStylesClient.js in ./src/css/app.css, ./src/css/icons.css
* !!../../..!Catopes2/node_modules/css-loader/index.js??ref--5-1!../../..!Catopes2/node_modules/postcss-loader/lib/index.js??ref--5-2!../../..!Catopes2/src/css/app.css in ./src/css/app.css
* !!../../..!Catopes2/node_modules/css-loader/index.js??ref--5-1!../../..!Catopes2/node_modules/postcss-loader/lib/index.js??ref--5-2!../../..!Catopes2/src/css/icons.css in ./src/css/icons.css
* !../../../..!Catopes2/node_modules/vue-style-loader/lib/addStylesClient.js in ./node_modules/framework7/css/framework7.css
* !!../../../..!Catopes2/node_modules/css-loader/index.js??ref--5-1!../../../..!Catopes2/node_modules/postcss-loader/lib/index.js??ref--5-2!../../../..!Catopes2/node_modules/framework7/css/framework7.css in ./node_modules/framework7/css/framework7.css
* C:\Users\User\Desktop\!Catopes2\node_modules\webpack-dev-server\client\index.js?http://localhost:8081 in multi (webpack)-dev-server/client?http://localhost:8081 webpack/hot/dev-server ./src/main.js

package.json

{
  "name": "framework7-template-vue-webpack",
  "version": "2.0.0",
  "description": "Framework7 Vue Webpack starter app template",
  "scripts": {
    "dev": "webpack-dev-server --inline --progress --config build/webpack.dev.conf.js",
    "start": "npm run dev",
    "build": "node build/build.js",
    "copy-fonts": "cpy node_modules/framework7-icons/fonts/*.* src/fonts && cpy node_modules/material-design-icons/iconfont/*.{eot,ttf,woff,woff2} src/fonts",
    "postinstall": "npm run copy-fonts"
  },
  "repository": {
    "type": "git",
    "url": "git+https://github.com/framework7io/framework7-template-vue-webpack.git"
  },
  "keywords": [
    "ios",
    "webpack",
    "framework7",
    "vue",
    "vuejs",
    "material",
    "mobile",
    "app",
    "f7"
  ],
  "author": "Vladimir Kharlampidi",
  "license": "MIT",
  "bugs": {
    "url": "https://github.com/framework7io/framework7-template-vue-webpack/issues"
  },
  "homepage": "http://framework7.io/vue/",
  "dependencies": {
    "framework7": "^3.4.0",
    "framework7-icons": "^0.9.1",
    "framework7-vue": "^3.4.0",
    "material-design-icons": "^3.0.1",
    "vue": "^2.5.17"
  },
  "devDependencies": {
    "autoprefixer": "^7.2.6",
    "babel-core": "^6.26.3",
    "babel-helper-vue-jsx-merge-props": "^2.0.3",
    "babel-loader": "^7.1.5",
    "babel-plugin-syntax-jsx": "^6.18.0",
    "babel-plugin-transform-runtime": "^6.22.0",
    "babel-plugin-transform-vue-jsx": "^3.7.0",
    "babel-preset-env": "^1.7.0",
    "babel-preset-stage-2": "^6.22.0",
    "chalk": "^2.4.1",
    "copy-webpack-plugin": "^4.5.2",
    "cpy-cli": "^1.0.1",
    "css-loader": "^0.28.11",
    "extract-text-webpack-plugin": "^3.0.0",
    "file-loader": "^1.1.11",
    "friendly-errors-webpack-plugin": "^1.7.0",
    "html-webpack-plugin": "^2.30.1",
    "node-notifier": "^5.1.2",
    "optimize-css-assets-webpack-plugin": "^3.2.0",
    "ora": "^1.4.0",
    "portfinder": "^1.0.17",
    "postcss-import": "^11.1.0",
    "postcss-loader": "^2.1.6",
    "postcss-url": "^7.3.2",
    "rimraf": "^2.6.0",
    "semver": "^5.5.1",
    "shelljs": "^0.7.6",
    "uglifyjs-webpack-plugin": "^1.3.0",
    "url-loader": "^0.5.8",
    "vue-loader": "^13.7.3",
    "vue-style-loader": "^3.1.2",
    "vue-template-compiler": "^2.5.17",
    "webpack": "^3.12.0",
    "webpack-bundle-analyzer": "^2.13.1",
    "webpack-dev-server": "^2.11.3",
    "webpack-merge": "^4.1.4"
  },
  "engines": {
    "node": ">= 6.0.0",
    "npm": ">= 3.0.0"
  },
  "browserslist": [
    "> 1%",
    "last 2 versions",
    "not ie <= 8"
  ]
}

#2

The problem in Windows … on Linux run fine, I will continue to try :wink:


#3

Webpack 4 version work fine on windows, thanks Vladimir! :+1: