Update minimatch for install Framework7


#1

Hello,
i try to install Framework7 on my MAC High Sierra.

When i digit this command: “sudo nom install --global gulp” i have this error:

sudo npm install --global gulp
npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated [email protected]: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to [email protected]^4.0.0 as soon as possible. Use ‘npm ls graceful-fs’ to find it in the tree.
/usr/local/bin/gulp -> /usr/local/lib/node_modules/gulp/bin/gulp.js

I try to update ma nothing.

Help me please.
Regards


#2

npm install -g [email protected]

could be an option try to have but try
npm view minimatch version
and npm update -g minimatch I hope it’s your help


#3

The command update the minimatch but the result is egual. not minimatch is updated


#4

I will suggest you to try to install latest versions of Node and NPM (https://nodejs.org/en/)


#5

But to use F7 you don’t need this. Just grab the JS and CSS files from the dist folder from the downloaded package and follow the Getting Started guide http://framework7.io/docs/get-started.html


#6

I have installed the last version of node and NPM. I try to upgrade but i have the same problem. After i have tested the F7 and it’s work!!! strange.
Thanks at all.