Anchors not working in ios

I have an app that I build in cordova and is working fine on android and browser. I was even able to build with adobe phonegap build for submission to the app store, so I know it works. Due to recent adobe changes, I have tried to build on a new mac and although it builds and I can run it, some of the navigation functionality is not working ?

I think I have built it properly and I did some reading and see something similar here: [SOLVED] WKWebViewOnly = true , not routing for next view

I tried adding the wkwebviewonly package but it won’t compile and searches for the error give me :
https://github.com/apache/cordova-plugin-wkwebview-engine/issues/142

It says that webview is now builtin, so I am wondering if anyone else has an idea of the problem of why my menu links and anchor tags don’t seem to navigate on ios, knowing they do on adobe and the same code was used to build ios before?

Hi @pworthing, are you compiling with cordova @ios 6.1+?
Can you please share your config.xml ?

Hi , thanks for your help. I can send It if needed but I think this has more info included. Let me know otherwise:
[email protected] AlceaMobileApp % cordova info

Cordova Packages:

cli: 10.0.0
    common: 4.0.2
    create: 3.0.0
    lib: 10.0.0
        common: 4.0.2
        fetch: 3.0.0
        serve: 4.0.0

Project Installed Platforms:

ios: 6.1.0

Project Installed Plugins:

com.googlemaps.ios: 3.9.0
cordova-plugin-camera: 4.1.0
cordova-plugin-file: 6.0.2
cordova-plugin-geolocation: 4.0.2
cordova-plugin-googlemaps: 2.7.1
cordova-plugin-inappbrowser: 4.0.0
cordova-plugin-secure-storage: 3.0.2
cordova-plugin-statusbar: 2.4.3
cordova-plugin-whitelist: 1.3.4

Environment:

OS: macOS Catalina 10.15.6 (19G2021) (darwin 19.6.0) x64
Node: v12.18.3
npm: 6.14.7

ios Environment:

xcodebuild:

Xcode 11.6
Build version 11E708

Project Setting Files:

config.xml:
<?xml version='1.0' encoding='utf-8'?> AlceaMobileApp A mobile interface for Alcea Tracking Solutions Alcea Technologies Inc. This app needs camera access to take pictures for tickets This app needs photo library access to get pictures for ticket attachments This app needs location access to add current location markers to maps This app needs photo library access to save pictures which might be used later
package.json:

— Start of Cordova JSON Snippet —
{
“plugins”: {
“cordova-plugin-camera”: {
“ANDROID_SUPPORT_V4_VERSION”: “27.+”
},
“cordova-plugin-file”: {},
“cordova-plugin-whitelist”: {},
“cordova-plugin-statusbar”: {},
“cordova-plugin-geolocation”: {},
“cordova-plugin-secure-storage”: {},
“cordova-plugin-inappbrowser”: {},
“cordova-plugin-googlemaps”: {}
},
“platforms”: [
“browser”,
“android”,
“ios”
]
}
— End of Cordova JSON Snippet —

Looks like this fixes it

THanks nolimits4web