Android app doesn't build to Kitkat 4.4.4 well


I just started a fresh new, empty app in Framework7, exactly following the steps described here:

I created Android+Web app, the browser version runs perfectly, without any errors.

The Android, however, doesn’t install. I generated APK with:

npm run build-cordova-prod (also tried build-cordova-dev)

When I copy it to my Android (Kitkat 4.4.4) it says:

There is a problem parsing the package.

I also tried to run it from cordova directory, with “cordova run android” (USB debuggging enabled), but I got the following message:

Failed to install apk to device:



Thank you very much for your help!


Aside of the apk SDK error. You should know that F7-v4 is only supported on andriod +5


Thank you very much! That is absolutely useful to know and I failed to find this information before on official resources. Although it does not explain the APK error, it points me to look for compatible alternative, which hopefully will work better together.

give a look in Android bundles, in Android Studio, i believe can us create apk with more one compilation to assegure all types of Android. Compile and distribute especific type of app for a correct Android version, then you use a framework7 v1,v2 or v3 and make a another app to Android 4.4.4. I dont make this, but i have that intention, im need to estudy more of that, hope help you.