App stuck on load


just get started and created my first app using framework7 (without any customization, just used “framework7 create” command. thats it) , and trying to deploy to my device and android emulator, unfortunately, the app unable to load completely and got stuck, the below screenshot from emulator.

please advise what should I check and how to fix it?, even-though, using http-serve I can see in the chrome browser the app can load smoothly.

thank you.

Set AutoHideSplashScreen = true
And SplashScreenDelay = 2000
In config.xml in Cordova folder

1 Like

Thanks @sandeepbhor for your feedback.

I don’t get same screen issue like earlier, but now the app still stuck with below screen:

please advise.

is there any way to debug this kind of issue? I am still trying to get used to develop using this framework and also develop using visual studio code.

thank you.

What command you are giving to load on device?

Above screenshot, I tried using this below command.

framework7 cordova run android

also, I tried with build APK and deploy manually to emulator and my phone and got same issue. this below command I used to build the APK.

framework7 cordova build android

To make APK give command
npm run build-cordova-android

And to run on emulator, first start the emulator and then give command
npm run cordova-android

@sandeepbhor , thanks for you help…
its working now, but I need to bit modify the command given

I need to remove “-android” in the command, to be like below.

to build APK:

npm run build-cordov

to run on emulator:

npm run build-cordova

I will close this topic, but if you can let me know why I should remove “-android” in the command, it will be really appreciated.

thanks again.

May be when you created the project you may have selected only android.

Try to create project with the command
frameworK7 create --ui
It will give you the exact possible commands after creating the project.

This screen is the default Home Screen for a new, blank Cordova app. It’s what you see when no other HTML/CSS/JS has been added to the project. It is merely saying that Cordova has been loaded and the deviceReady() event has been fired… Hence why the text says ‘device is ready’.

If you’ve added your own project files and you’re still seeing this screen, it’s possible your build sequence is not incorporating your files into the project, and only showing the default Cordova files that were created when the project was built.