Camera not coming up in f7-core with capacitor

I’m aware of pretty much all available react/vue/ionic and cordova examples,
a similar question was answered with a reference to the haptic example from capacitor,
Trouble: it should work, but it doesn’t - calling for help now.

  • using the f7-ui I’ve created a simple project (not PWA) using capacitor and vite.
  • I’ve added camera, geolocation and even pwa-elements then install / build / -build-ios / -build-android etc.
  • in the app.js I’m importing {Camera, … }
  • in app /new Framework7 I’m setting Camera: Camera, (right underneath routes)
  • in tester.f7 I’m calling takePicture() async/await Camera.getPhoto()
  • calling it from a button
  • all console.logs(n) are hit!
  • no major error messages on emulator or real device other than expected (e.g. not defined in web)
  • Camera is not even starting,
  • no webPath is returned.

IF any of you could build a simple app based on F7-core (only) + vite with the capacitor and camera/geolocation plugin working I’d be happy to push the Paypal button again … (any help is appreciated, but don’t start blindly).

(I’ve looked at the whatsApp example which is using react and the mediaService as PWA - can’t use it)

I believe many more people could greatly benefit from a workking example of F7-core + capacitor, too.

Thanks in advance,

PS: usually I’m the one helping others - so funny… THX

btw, line 45/46 is just a wild guess

[SOLVED] - The import of Camera doesn’t work globally (app.js) but needs to go into the local section of the page(s) where needed (right before export).
A better way might be to add or import additional plugins to the capacitor-app; However, this works now on f7-core. THX and happy coding.