Creating a New App using Framework7 CLI

Hi All,

I am trying to create a new Framework7 App using command Framework7 create --ui

But I am getting the following errors:
For Vite it is recommended to have modern and latest Node.js and NPM.
Make sure you have at least Node.js v14 and NPM v7 installed on your system.
(node:10636) [DEP0128] DeprecationWarning: Invalid ‘main’ field in ‘C:\Users\Administrator\AppData\Roaming\npm\node_modules\cordova\node_modules\objectorarray\package.json’ of ‘dist/index.js’. Please either fix that or report it to the module author
(Use node --trace-deprecation ... to show where the warning was created)
Failed to fetch plugin [email protected] via registry.
Probably this is either a connection problem, or plugin spec is incorrect.
Check your connection and plugin name/version/URL.
CordovaError: CordovaError: Could not determine package name from output:
added 2 packages, and audited 3 packages in 2s

found 0 vulnerabilities

I have tried it on three machines, I still get the same results.
C:\Users>node -v

C:\Users>npm --version

What might be wrong?

Try running your terminal/command window with Administrator privilidiges. Also try a ping to or to confirm a successful connection.