Creating Cordova project (Please wait, it can take a while)

I am creating an application in iOS and Android both using vue js. I have installed every needed part step by step but after writing framework7 create --ui the step of creating cordova project had took more than half an hour creating but it is still not done. I am not getting what to do. Please help me with that.

Can you tell us what versions of NPM, Node and Cordova you have installed?

You can try to create a dummy cordova project from the terminal / command line, to get the cordova error. That error is probably hidden behind the Framework7 ui.

NPM version is :6.14.9
Node version is : 14.15.3
Cordova version is : 10.0.0

How to do that can you please give the command for creating in the CLI.

Try cordova create TestApp on the command line/terminal to see what errors may be occuring.

The Error is : powershell (Get-CimInstance -ClassName Win32_OperatingSystem).caption
‘powershell’ is not recognized as an internal or external command,
operable program or batch file.

I have shared the error please check it do you know how to solve it it will help me a lot.

Try running it with Administrator privileges.

same error as I have mentioned above

Can you try seeing if you have Powershell installed on your Windows machine? Open the command prompt and type ‘powershell’ and see if it executes. The command prompt should change to have ‘PS’ at the start of the new line.

Potentially there are issues with the latest release of Cordova:

I have solved that issue now the new error is Command failed with exit code 1: E:\ChatIn\cordova\platforms\android\gradlew cdvBuildDebug -b E:\ChatIn\cordova\platforms\android\build.gradle
npm ERR! errno 1
npm ERR! [email protected] cordova-android: cross-env TARGET=cordova cross-env NODE_ENV=development node ./build/build.js && cd cordova && cordova run android
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] cordova-android script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\Fundestroyer\AppData\Roaming\npm-cache_logs\2021-01-09T05_12_53_159Z-debug.log

Your build seems to be failing because licenses are not being accepted. Take a look at this post to find a solution: