Error Framework7-CLI

I have the following error when I try to execute the commands to add a platform:

framework7 cordova platform add ios

Current working directory is not a Cordova-based project.
(node:17833) UnhandledPromiseRejectionWarning: Error: Shell command exit with non zero code: 1
    at ChildProcess.<anonymous> (/usr/local/lib/node_modules/framework7-cli/node_modules/exec-sh/lib/exec-sh.js:73:15)
    at ChildProcess.emit (events.js:315:20)
    at maybeClose (internal/child_process.js:1048:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:288:5)
(Use `node --trace-warnings ...` to show where the warning was created)
(node:17833) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see (rejection id: 1)
(node:17833) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

I have the same error

I have the same problem.

Uninstall all, que and re install.

Update node.js

Can you please indicate what version of nodejs worked for you.

Node 12, in your Shell use: cd cordova
After add comando add platform ios