F7 CLI installation issue

I tried to create a new/clean F7 instance (with CLI) and I got this errors,
npm WARN deprecated [email protected]: Please see https://github.com/lydell/urix#deprecated

npm WARN deprecated [email protected]: The package has been renamed to open

npm WARN deprecated [email protected]: https://github.com/lydell/resolve-url#deprecated

any idea how to fix it?

It doesn’t seem like errors, what you posted are just warning that can be ignored

Thank you Vladimir, but when I ran ‘npm run start’ I got webpack error (simple web app, F7 Core, single view, Webpack, default colors, include icons)

[webpack-cli] Invalid options object. Dev Server has been initialized using an options object that does not match the API schema.

  • options has an unknown property ‘disableHostCheck’. These properties are valid:
    object { allowedHosts?, bonjour?, client?, compress?, devMiddleware?, headers?, historyApiFallback?, host?, hot?, http2?, https?, ipc?, liveReload?, magicHtml?, onAfterSetupMiddleware?, onBeforeSetupMiddleware?, onListening?, open?, port?, proxy?, setupExitSignals?, static?, watchFiles?, webSocketServer? }

Webpack? latest/newest CLI doesn’t use Webpack at all, probably it is the project created with old CLI? Then follow the messages and tweak Webpack config, try removing disableHostCheck property if it is there

Hmm, framework7-cli ver. is 5.0.6, I tried to install clean F7 with Svelte option and I got webpack error as well.

npm view shows remote version, not installed on your machine. You fore sure somehow use old version as there no anything related to Webpack in latest CLI

Oops, my bad! You’re right, somehow I have 7.5.6 crazy and I can’t remove it. :frowning:

I tried, sudo npm uninstall -g [email protected]