[F7v6+Vue] Can't install any working Apollo version compatible with Vue v3

I’ve got a question. I can’t get Apollo working with Vue v3. Every time I get dependency error while installing @vue/apollo-composable thus can’t possibly integrate Apollo with my app. Did anybody encounter this problem? If so, how did you handle it?

"
$ npm install --save @vue/apollo-composable
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: [email protected]
npm ERR! Found: [email protected]
npm ERR! node_modules/vue
npm ERR! [email protected]"~3.1.1" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer [email protected]">= 2.5 < 3" from @vue/[email protected]
npm ERR! node_modules/@vue/composition-api
npm ERR! peer @vue/[email protected]"^1.0.0-beta.16" from @vue/[email protected]
npm ERR! node_modules/@vue/apollo-composable
npm ERR! @vue/[email protected]"*" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
"

Thanks

1 Like