Framework7 CLI, conflicting peer dependency webpack 4.44.2 with npm version 7

With the new version of node 7 it seems the webpack versions are conflicting now,
I tried to downgrade upgrade and still the same issue.

Which webpack version need the latest version of framework7 CLI?


npm list -g

running inside my new dir

framework7 create using webpack

my npm version 7.1.2.

Any ideas how to fix this webpack issue and make framework7 create to work without errors?


I downgrade node to version 6 and now it works!

delete npm first:

sudo rm -rf /usr/local/bin/npm /usr/local/share/man/man1/node.1 /usr/local/lib/dtrace/node.d

sudo rm -rf /opt/local/bin/node /opt/local/include/node /opt/local/lib/node_modules 

sudo rm -rf /usr/local/bin/npm /usr/local/share/man/man1/node* /usr/local/lib/dtrace/node.d ~/.npm ~/.node-gyp 

Reinstalled node version node-v14.15.1.pkg

Now it works with:

npm version 6.14.8
node version v14.15.1

It seems the last version of node it conflicts with framework7 and webpack dependencies!

Any solution for npm version 7?

I could build the new project folder using

framework7 create

but when I run

npm run start


run build-dev-cordova-ios

gives me this error:

> cross-env NODE_ENV=development webpack-dev-server --config ./build/webpack.config.js
TypeError: compilation.getCache is not a function
npm ERR! errno 1
npm ERR! .... cross-env NODE_ENV=development webpack-dev-server --config ./build/webpack.config.js

I tried to update the framework7 CLI and everything and the problem is still there…

any tips?

framework7 -V is 3.4.5
npm -v is 6.14.8
node -v is v14.15.1
cordova -v is 10.0.0


This helped me a lot with the above issue thanks Vladimir!

This is what I did!

I edited the package.json of my framework7 folder and inside package.json changed this line copy-webpack-plugin from “^7.0.0” to “^6.2.1”

"copy-webpack-plugin": "^6.2.1", //this works

then I renamed node_modules folder to be sure all modules are installed again correctly by running

npm install

the copy-webpack-plugin is now downgraded to 6.2.1. If I run

npm run start


run build-dev-cordova-ios

It will not produce anymore that error above!

Thank you to all for the quick fix explanation!

This worked for me (after 7 hours of trying other things!). Thanks ‘nolimits4web’.

1 Like