Framework7 Core v5.0.4 npm run build-prod-cordova-android Stuck on Build Complete

“npm run build-prod-cordova-android” after run this CLI, build stuck on complete and couple of hour spend to wait for it but no response. Before this (5.0.4) Version I was using this
“framework7”: “^4.4.7”

“framework7”: “^5.0.4” Screen Short ------> http://prntscr.com/pj2cyl

“framework7”: “^4.4.7” Screen Short ------> http://prntscr.com/pj2biy

Thanks in Advance :slight_smile:

3 Likes

My problem is just like you

Looking for a solution? :slight_smile:

Looking for a solution? :slight_smile:

@nolimits4web any solution for this issue?

Framework7-CLI version: 3.0.5
Framework7:  5.0.5

I am also having the same issues.

1 Like

anybody fixed this problem??

waiting…

If you are doing less for Android and IOS. then no issue for you. after Build Complete. then press ctr + c and type “y” and Enter for run this command. Then type this command for run and also for build.

"framework7 cordova run android"
"framework7 cordova build android"

2 Likes

I too am facing similar problems - sometimes it builds ok, but 80% of the time it just hangs and I have to force close it - need a fix quick

Here is an other discussion on the topic: https://forum.framework7.io/t/error-running-electron-app-generated-from-f7-cli/8539/12?u=vbguyny

Same issue here.

@Hadley solution really works, because the build is in fact complete.

1 Like