Impossible to compile app.... compilation.getCache is not a function

hi everybody… since yesterday night impossible to compile project or launch it in browser…
i ve created new project but still the same error…
i have reinstall the whole computer and reinstall all the components… jdk, sdk, graddle, nodejs…
and create new project with framework7 cli… but still the same error… i have checked on the net the said that i must do a webpack upgrade… i ve done it and create new project but still impossible to launch project on browser or compile it…
but when i compile a simple cordova project it works
please guys help me

1 Like

i have the same problem
node v15.3.0
latest cordova and framework7-cli
created project with cli and cli --ui


please how have you solve the problem ?

i downgraded copy-webpack-plugin to version 6.2.1
seems to work fine for now

1 Like

please how have you do it ? is it command line ? can you send me the method? please thanks a lot…

1 Like
npm uninstall copy-webpack-plugin
npm install [email protected]

Edit package.json and change ^7.0.0 to ^6.2.1

"copy-webpack-plugin": "^6.2.1"

Then run npm install in command line

Which will uninstall current version and install the required version.


I was just starting Framework 7 for the first time and following religiously the tutorial and hit this bug.
This is worst, than it looks, I almost gave up on Framework 7.

what? why?
Just install “copy-webpack-plugin”: “^6.2.1” and the problem is solved.
Seems straight forward to me.

1 Like

it worked for me thanks a lot

1 Like