Installing Framework7

I am at the point where it is installing the assets but it’s been about 20 minutes. Is there something that is hanging up the installation? This is the cmdline documentation.

I get it says this could take a while but not expecting 20-25 minutes. I thought maybe it was stuck somewhere.

  • Generating assets (Please wait, it can take a while)(node:38288) UnhandledPromiseRejectionWarning: TypeError: Cannot read property ‘platforms’ of undefined
    at generateAssets (C:\Users\Mike\AppData\Roaming\npm\node_modules\framework7-cli\generate-assets\index.js:39:19)
    at Command.program.command.option.option.description.action (C:\Users\Mike\AppData\Roaming\npm\node_modules\framework7-cli\index.js:90:13)
    at process._tickCallback (internal/process/next_tick.js:68:7)
    (node:38288) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 2)
    (node:38288) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
    \ Generating assets (Please wait, it can take a while)

Nothing happened but I tried running npm run core:prod and got the following log

0 info it worked if it ends with ok
1 verbose cli [ ‘C:\Program Files\nodejs\node.exe’,
1 verbose cli ‘C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js’,
1 verbose cli ‘run’,
1 verbose cli ‘core:prod’ ]
2 info using [email protected]
3 info using [email protected]
4 verbose config Skipping project config: C:\Users\Mike/.npmrc. (matches userconfig)
5 verbose stack Error: missing script: core:prod
5 verbose stack at run (C:\Program Files\nodejs\node_modules\npm\lib\run-script.js:155:19)
5 verbose stack at C:\Program Files\nodejs\node_modules\npm\lib\run-script.js:63:5
5 verbose stack at C:\Program Files\nodejs\node_modules\npm\node_modules\read-package-json\read-json.js:115:5
5 verbose stack at C:\Program Files\nodejs\node_modules\npm\node_modules\read-package-json\read-json.js:418:5
5 verbose stack at checkBinReferences_ (C:\Program Files\nodejs\node_modules\npm\node_modules\read-package-json\read-json.js:373:45)
5 verbose stack at final (C:\Program Files\nodejs\node_modules\npm\node_modules\read-package-json\read-json.js:416:3)
5 verbose stack at then (C:\Program Files\nodejs\node_modules\npm\node_modules\read-package-json\read-json.js:160:5)
5 verbose stack at C:\Program Files\nodejs\node_modules\npm\node_modules\read-package-json\read-json.js:280:12
5 verbose stack at C:\Program Files\nodejs\node_modules\npm\node_modules\graceful-fs\graceful-fs.js:78:16
5 verbose stack at FSReqWrap.readFileAfterClose [as oncomplete] (internal/fs/read_file_context.js:53:3)
6 verbose cwd C:\Users\Mike
7 verbose Windows_NT 10.0.17763
8 verbose argv “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” “run” “core:prod”
9 verbose node v10.15.3
10 verbose npm v6.4.1
11 error missing script: core:prod
12 verbose exit [ 1, true ]

Try install latest LTS NodeJS and follow the instructions