Issues running "cordova run android" for MacOS

Hi, I currently have set up a properly built app with the framework7 cli, I had no issues throughout the development process.

However, after building the Cordova app I tried running the command “cordova run android” to simulate the app on the android emulator.

PS: I have already downloaded the android studio and configured my AVD manager.

This is the error message i get whenever I run the command.

Checking Java JDK and Android SDK versions
ANDROID_SDK_ROOT=undefined (recommended setting)
ANDROID_HOME=/Users/rockhafella/Library/Android/sdk/ (DEPRECATED)
Requirements check failed for JDK 8 (‘1.8.*’)! Detected version: 13
Check your ANDROID_SDK_ROOT / JAVA_HOME / PATH environment variables.

Please, I’ll appreciate any help because I have been on this for the past 2 days.


what version of jdk are you using?

javac -version

also, set your environment var



Thanks for ur reply.

Apparently Cordova is strict on the Java sdk version to use.

I had Java 13 running as the default Java version, so I had to install Java 8 sdk and added it to my environment variables in .bash_profile

That solved the issue.


hello please i have same issues how do i set the environment variables in .bash_profile