New project using framework7-cli fonts not showing

Hello folks,

I’ve just began using Framework7 and following the instructions here Framework7 Command-Line Interface

framework7 version = 4.0.7

I used the CLI UI app to generate the project from the templates. Specifically using the Framework7 with Svelte. App types I have tried have been www and pwa.

In all cases I am not seeing any icons - at all. I did have one instance where I could see the menu icons but have since been unable to see them.

I have deleted the project and tried again and nothing.

Not sure what I can show here - I’ve literally added a new project and npm run start.

Project structure (showing fonts/css) appears as:

Does anybody have any suggestions on things I can try?


Just created same and have no any issues:

Thank you for replying.

Ok, so the element you used in your example is different from that in the template.

In the template a link, with icons is:

<Link iconIos="f7:menu" iconAurora="f7:menu" iconMd="material:menu" panelOpen="left" />

Your example is using <Icon material="home" />

when i use your example it’s good, the template isn’t.

Does this help?


I think I am beginning to understand the framework a little more now. If i set the theme within that page to ios then the icons show up.

As a side-Q to the above, how does one set the theme to be ios when using the svelte plugin? All the examples I have found have the theme being set when creating a new Framework7() object; however the template uses the plugin and I’m not sure how to set the theme for the entire app.

Thanks again, and great work on this framework, it’s real slick.

Ok, actually I see there is an issue, and it can’t correctly detect theme in initial (first) page. Will be fixed in 6.0.10 update

1 Like

Beautiful! Thanks so much