Npm run start failed in framework7 Core latest version

I have just created a new project with Framework7 Core latest version. But it shows error when I run npm run start command

Can you please give me solution?

Update Framework7-CLI to latest 3.3.1 version and try again to create the project

I have just created the app by framework7 create --ui and I have latest cli version. But still it shows that error.
2/3 days ago I created an app and it was ok. But today it is showing this error for new app

Now it is showing this

Just USE npm start

Am getting the same error. Even npm start is throwing the same same error.

npm 6.14.5
[email protected]

[email protected]:/opt/lampp/htdocs/apps/covidtracer/mobile$ npm start
> [email protected] start /opt/lampp/htdocs/apps/covidtracer/mobile
> npm run dev
> [email protected] dev /opt/lampp/htdocs/apps/covidtracer/mobile
> cross-env NODE_ENV=development webpack-dev-server --config ./build/webpack.config.js

ℹ 「wds」: Project is running at http://localhost:8081/
ℹ 「wds」: webpack output is served from /
ℹ 「wds」: Content not from webpack is served from /www/
ℹ 「wds」: 404s will fallback to /index.html
ℹ 「wdm」: wait until bundle finished: /
✖ 「wdm」: Hash: 36e5bd7f16455d0d52df
Version: webpack 4.43.0
Time: 12963ms
Built at: 05/16/2020 12:12:23 PM
                          Asset      Size  Chunks             Chunk Names
                   ./index.html  1.14 KiB          [emitted]  
fonts/Framework7Icons-Regular.eot   292 KiB          [emitted]  
fonts/Framework7Icons-Regular.ttf   291 KiB          [emitted]  
fonts/Framework7Icons-Regular.woff   145 KiB          [emitted]  
fonts/Framework7Icons-Regular.woff2   108 KiB          [emitted]  
fonts/MaterialIcons-Regular.eot   140 KiB          [emitted]  
fonts/MaterialIcons-Regular.ttf   125 KiB          [emitted]  
fonts/MaterialIcons-Regular.woff  56.3 KiB          [emitted]  
fonts/MaterialIcons-Regular.woff2  43.3 KiB          [emitted]  
                      js/app.js  3.16 MiB     app  [emitted]  app
Entrypoint app = js/app.js
[0] multi (webpack)-dev-server/client?http://localhost:8081 (webpack)/hot/dev-server.js ./src/js/app.js 52 bytes {app} [built]
[./node_modules/dom7/dist/dom7.module.js] 45.3 KiB {app} [built]
[./node_modules/framework7/css/framework7.bundle.css] 1.63 KiB {app} [built]
[./node_modules/framework7/framework7.esm.bundle.js] 5.82 KiB {app} [built]
[./node_modules/strip-ansi/index.js] 161 bytes {app} [built]
[./node_modules/webpack-dev-server/client/index.js?http://localhost:8081] (webpack)-dev-server/client?http://localhost:8081 4.29 KiB {app} [built]
[./node_modules/webpack-dev-server/client/overlay.js] (webpack)-dev-server/client/overlay.js 3.51 KiB {app} [built]
[./node_modules/webpack-dev-server/client/socket.js] (webpack)-dev-server/client/socket.js 1.53 KiB {app} [built]
[./node_modules/webpack-dev-server/client/utils/createSocketUrl.js] (webpack)-dev-server/client/utils/createSocketUrl.js 2.91 KiB {app} [built]
[./node_modules/webpack-dev-server/client/utils/log.js] (webpack)-dev-server/client/utils/log.js 964 bytes {app} [built]
[./node_modules/webpack-dev-server/client/utils/reloadApp.js] (webpack)-dev-server/client/utils/reloadApp.js 1.59 KiB {app} [built]
[./node_modules/webpack-dev-server/client/utils/sendMessage.js] (webpack)-dev-server/client/utils/sendMessage.js 402 bytes {app} [built]
[./node_modules/webpack/hot sync ^\.\/log$] (webpack)/hot sync nonrecursive ^\.\/log$ 170 bytes {app} [built]
[./node_modules/webpack/hot/dev-server.js] (webpack)/hot/dev-server.js 1.59 KiB {app} [built]
[./src/js/app.js] 1.18 KiB {app} [built]
+ 325 hidden modules

LOG from copy-webpack-plugin
<e> unable to locate '/opt/lampp/htdocs/apps/covidtracer/mobile/src/static' at '/opt/lampp/htdocs/apps/covidtracer/mobile/src/static/**/*'
+ 7 hidden lines

ERROR in unable to locate '/opt/lampp/htdocs/apps/covidtracer/mobile/src/static' at '/opt/lampp/htdocs/apps/covidtracer/mobile/src/static/**/*'

ERROR in   Error: Child compilation failed:
unable to locate '/opt/lampp/htdocs/apps/covidtracer/mobile/src/static' at '/opt/lampp/htdocs/apps/covidtracer/mobile/src/static/**/*'

- child-compiler.js:122 
[mobile]/[html-webpack-plugin]/lib/child-compiler.js:122:18

- Compiler.js:343 
[mobile]/[webpack]/lib/Compiler.js:343:11

- Compiler.js:681 
[mobile]/[webpack]/lib/Compiler.js:681:15


- Hook.js:154 AsyncSeriesHook.lazyCompileHook
[mobile]/[tapable]/lib/Hook.js:154:20

- Compiler.js:678 
[mobile]/[webpack]/lib/Compiler.js:678:31


- Hook.js:154 AsyncSeriesHook.lazyCompileHook
[mobile]/[tapable]/lib/Hook.js:154:20

- Compilation.js:1423 
[mobile]/[webpack]/lib/Compilation.js:1423:35


- Hook.js:154 AsyncSeriesHook.lazyCompileHook
[mobile]/[tapable]/lib/Hook.js:154:20

- Compilation.js:1414 
[mobile]/[webpack]/lib/Compilation.js:1414:32


- Hook.js:154 AsyncSeriesHook.lazyCompileHook
[mobile]/[tapable]/lib/Hook.js:154:20

- Compilation.js:1409 
[mobile]/[webpack]/lib/Compilation.js:1409:36



Child HtmlWebpackCompiler:
 1 asset
Entrypoint HtmlWebpackPlugin_0 = __child-HtmlWebpackPlugin_0
[./node_modules/html-webpack-plugin/lib/loader.js!./src/index.html] 1.71 KiB {HtmlWebpackPlugin_0} [built]

LOG from copy-webpack-plugin
<e> unable to locate '/opt/lampp/htdocs/apps/covidtracer/mobile/src/static' at '/opt/lampp/htdocs/apps/covidtracer/mobile/src/static/**/*'
+ 7 hidden lines

ERROR in unable to locate '/opt/lampp/htdocs/apps/covidtracer/mobile/src/static' at '/opt/lampp/htdocs/apps/covidtracer/mobile/src/static/**/*'
ℹ 「wdm」: Failed to compile.

@nolimits4web is there a way I can use previous version of CLI to create a new project? Like use 3.3.0 instead of 3.3.1?

I am trying to troubleshoot this issue. Am still not able to run a new cordova project since updating to CLI 3.3.1 and npm 6.14.5. I have rolled back to npm 6.14.4, and CLI 3.3.0, but am not able to use he CLI without updating to 3.3.1. Am getting the same error above.

I’m also getting the same error. Looks like new update broke something.

Please select Web App(WWW) and Cordova both platform before creating app

Please select Web App(WWW) and Cordova both platform before creating app.

Thanks, it solved the error. I would still think that @nolimits4web needs to look into this matter.

Yeah, selecting both web and cordova works

maybe you remove this folder

remove android and ios form your project.
and then re-install again

That folder is created by the installer. I did not add it manually

Thanks, this works for me also. I also think @nolimits4web should look into this issue. I have spent days on the internet searching for solution until I came to this forum.

@nolimits4web can look into issue but would be great if at least someone who has it will post proper way to replicate the issue, created project settings, node version, etc.

The main issue here is upgrading framework7 to 3.3.1

  1. So to replicate the issue first upgrade to that version
    npm update framework7

I believe that is what I did to upgrade and mine current version is:
C:\framework7\paymentdemo>framework7 --version
3.3.1

  1. create a new project
    framework7 create --ui

  2. select Cordova project only and select vue variant of framework.7 I did not test other variant.

  3. create project

  4. Run or build the project
    npm run start

The above steps will replicate the issue.

To resolve it, in step 3 above select Projects www and Cordova

Thanks

just remove platform android and add again, issue will resolved

selecting webapp with cordova is a much more hassle-free fix for this error

1 Like