Prevent iOSSwipeBack for certain route

So I have the following problem:
I am somehow “misusing” the <Tabs/> because, at least in my case, this results in a much clearer code.
I just have normal routes, which all display a <Tabbar/> which contain the following Links:

export default props => {
  const { f7route } = props;
  return (
    <div className="mobile-tabs">
      <Link href="/dashboard" className={ == 'dashboard' ? 'active' : ''} animate={false}>
        <Icon fa="truck" />
        <div className="bar" />
      <Link href="/history" className={ == 'history-buyer' ? 'active' : ''} animate={false}>
        <Icon fa="history" />
        <div className="bar" />
      <Link href="/profile" className={ == 'profile' ? 'active' : ''} animate={false}>
        <Icon fa="cog" />
        <div className="bar" />

But I have the following problem: If I switch from /dashboard to another page, e.g. /profile and then back to /dashboard (also via the Tabs), the following error occurs:

I can now “iOS-swipe-back” from /dashboard to an empty page, resulting in a completely blank screen. I don’t understand why.
I tried many ways to fix this, like options: { history: false, pushState: false } on all the routes which are linked in this Tabbar, but nothing fixes my problem.
I always end up with an “empty” ios swipe back, which is a huge problem as many users end up on this empty page and are stuck.

The error after swiping left to the empty page:

modules.js?hash=c7edb0678a8def4771b0c47b36707eaea9e9a1d9:71240 Uncaught TypeError: Cannot read property 'route' of undefined
    at Framework7.handleTouchEnd (modules.js?hash=c7edb0678a8def4771b0c47b36707eaea9e9a1d9:71240)
    at modules.js?hash=c7edb0678a8def4771b0c47b36707eaea9e9a1d9:67026
    at Array.forEach (<anonymous>)
    at modules.js?hash=c7edb0678a8def4771b0c47b36707eaea9e9a1d9:67025
    at Array.forEach (<anonymous>)
    at Framework7.emit (modules.js?hash=c7edb0678a8def4771b0c47b36707eaea9e9a1d9:67019)
    at emitAppTouchEvent (modules.js?hash=c7edb0678a8def4771b0c47b36707eaea9e9a1d9:68982)
    at HTMLDocument.appTouchEndPassive (modules.js?hash=c7edb0678a8def4771b0c47b36707eaea9e9a1d9:69013)

Can someone help?

Thanks, cheers, Patrick

Would be really helpful to see the live example with minimal issue reproduction. If you just interesting how to disable swipe-back for certain page, you can set its noSwipeback={true} prop