Routes Work In Web - Not In Android Build

I think this is a routes issue but I’m not totally sure and I’m not smart enough to know how to troubleshoot the issue myself so I’m hoping the get some feedback from you guys:

My environment:
Framework7 Core + Vite + Capacitor Android / iOS (but I am currently only building for Android)

What works:
If I run npm start - My app works flawlessly. It’s a fairly simple app it has tabs along the bottom, it has a settings cog at the top with an href to open /settings/ , and a big anchor with href on the front going to a different page in the app. These two load via ajax or what not in the browser the settings cog sliding down settings from the top and then dismissing it takes you back to the page you’re on.

Tabs at the bottom work which anchor to #tab-1 #tab-2 etc. The page starts on #tab-2 correctly. The ajax to pull my latest blog posts works.

<a href="#tab-1" class="tab-link" >
              <i class="icon f7-icons">sparkles</i>
              <span class="tabbar-label">Discover</span>

What doesn’t work:
When I build for Android if I click the cog or the main button link they don’t do anything. I get the touch animation that shows I hit it but nothing happens. I can only move between tabs on the same screen but not use routes.

<a href="/add-trip-form/" class="link link-banner link-chevron success-message">
				  <i class="icon f7-icons">airplane</i>
				  <div class="link-banner-text">
					<div class="link-banner-title">New Trip</div>
					<div class="link-banner-subtitle">Let's unlag that jetlag.</div>
                  <a href="/settings/" class="link icon-only navbar-profile">
                    <img src="img/icons/cog.png" alt="">

What I’ve Tried:
Not a lot to be honest, because I don’t know what is going wrong. There is a little console thing at the bottom of Android Studio that looks like a logger tool but it isn’t showing any errors or notices when I click a link.

So I figured out that it was that the pages/ directory I use to manage all my pages didn’t get added. I’m guessing there is some configuration that I need to set that as one of my directories. I cheated an just put it in public/ and now it’s working fine. Though I don’t think that’s the way I’m supposed to do it.