[SOLVED] Core v4 / v3 official template not working on mac


I am trying to clone and run this Core Webpack F7 Official template on my mac but I am miserably failing. I am running the latest git and node 10.15.1, installation finishes but on loading the app, I get these errors in the console which I dont have any idea where they come from… kindly help!

I need to start on v4 but I have been struggling with this since yetserday… thanks in advance!

Did you try to install using framework7 cli? (Maybe also updating your node-version helps…)
For me it works on my mac flawlessly…

Thanks @tiptronic, to be honest I thought about node too but yesterday I updated my node to v10.15.0 which is the latest recommended version but it has failed to work too. I tried to install f7-cli but also failed which prompted me to asking on the forum…

Did you actually check what it errored in error message. It looks like font file is missing. Is it actually there?

1 Like

Awesome… Issue sorted. I had assumed that fonts come packaged within the git repository.
All is well… Thanks so much and blessings!