Unable to build android or electron app

I have the newest version of cordova, framework7, npm…

When running any of the build processes I receive the following error for both assets/index..js and assets/vendor..js

“Failed to load module script: The server responded with a non-JavaScript MIME type of “”. Strict MIME type checking is enforced for module scripts per HTML spec.”

I even created a new app with the default single view and built without any changes with the same results.

Anyone have any ideas what is breaking in the system?

Make sure you have project created with latest F7 CLI and you build the project with npm run build-cordova Framework7 CLI 5.1.0

This is what I have been doing. I have the latest version of everything. I have run build-cordova and cordova-electron and build-cordova-android. Everything results in the same error. This has been tested on 2 computers and fresh installs of cordova and framework7.

There is an issue with the way framework7 builds the app. I only have this issue when building with vue. If I go to any other language it works fine. I think it is an issue with the way they included the libraries.

Would be more helpful if you post framework7.json file content here from the created project

This is the default document created by the framework7 cli

“cwd”: “C:\Users\Main\Desktop\Mobile Applications\Testing”,
“type”: [
“name”: “Testing”,
“pkg”: “com.testing.test”,
“framework”: “vue”,
“template”: “single-view”,
“cssPreProcessor”: false,
“bundler”: “vite”,
“cordova”: {
“folder”: “cordova”,
“platforms”: [
“plugins”: [
“theming”: {
“customColor”: false,
“color”: “#007aff”,
“darkTheme”: false,
“iconFonts”: true,
“fillBars”: false
“customBuild”: false

Just tried, everything works correct for me with freshly created project. Make sure you have project created with latest Framework7 CLI, to check that in your package.json scripts, there must be a node ./build/build-cordova.js script involved. And after the build in cordova/www/assets there must be only one index.[hash].js file, no vendors, etc.

If you’re building for Cordova why bother with the F7 CLI build anyway?

Since Cordova Android 10.0.0 and Cordova iOS 6.0.0 there has been support for WKWebView which means the following “just works” without the need to rollup any files

<script type="module" src="your-module.js"></script>

My in-development app runs fine on emulation without rolling anything up.

If this isn’t available to you, can you try sticking


in your script tags?

Also one final point, I don’t know if its a typo here or in your code, but your file names are

*assets/vendor.* .js

The forum formatted them to italics. What are the *'s doing?

Also why are there two periods in those filenames?