V2 Migration Guide

Hi guys, just finished the basic v1 to v2 migration guide where i tried to cover all the basic concepts that must be done to convert existing v1 app to v2.

Guide is available at https://blog.framework7.io/migration-to-framework7-v2-eb6dc38ede3b


Great news :grinning:

Thanks for the wonderful work of this migration guide and the new docs for v2!

I had worked in the dark for a few weeks and even had to dig into the source code when I migrated to v2 code few weeks ago. :frowning:

Now things are much clearer.

One major issue I found with v2 is regarding the router. It’s quite a big change. Now every navigation seems to need configuration in JS, which is cumbersome. Any more convenient way?

Otherwise, v2 is indeed much better than v1 in many ways. Thanks again for the wonderful work!

Congrats for the wonderful work of Framework7 v2 migration guide and the new docs!
I have read that you are working hard to update Framework7 Vue docs as well, which is great.
Do you have any plans to update app-framework with new Framework7 / Framework7-vue v2?
I am in a middle of an app development and will be great to make use of brand new versions.

To be honest, I’m very disappointed. Given the size of the application I’ve been working solely on for the past two years, the migration to v2 seems to be a huge burden and will take a considerable amount of time from my end.

I have 80 html template files and 35 javascript files in addition to the main index.html file which is not small. I’ll have to go through most of the files one by one to update!!!

1 Like

Great guide!

Though I’ve just tried to migrate to the latest 2.0.7 from a working version based 1.6.5.
I found that my links didn’t work at all… I followed the guide and set up all the routes when initiating Framework7. Still the same result. The app just wouldn’t load a sub page.

I even tried stripping the app from all but the foundation. Still no loading pages.

Any ideas of what could be wrong??

Show what you did, some examples, etc

Sorry for late reply!
The issue causing the error was burried in an linked in external js-library…
Removed it and all worked fine!

I spent time for migration is much more than my expectation, but it’s worth if you love the great new features and fixes in v2, no regret at all