V2 Nabber issue (with iOS)

I have just updated my app to V2 - it works fine on desktop versions of Safari and Chrome. However, when compiled for iOS with PhoneGap, the Navbar and its navigation icons disappears (just a blank space) - this on iOS 11.2.6 (iPad mini) and 11.3 beta (iPad Pro 10.5 and iPhone X). I copied the complete set of files onto my iPads and the same thing happens (the navbar disappears).
However, if I change the User Agent on my iPad to ‘Mac OSX’ the pure HTML files run perfectly well…
This suggests that Safari is not happy for some reason - suggestions for fixing this most welcome!

Anyone any thoughts on this please?

Looks like something wrong with the HTML layout. v2 has a bit different structure and navbar handling. The reason why it works correct on desktop because it uses there Material theme by default, rather than iOS theme

Thanks for the update.
I reviewed my code many times and even rewrote a couple of pages using F7 templates - but the navbar never worked…
I ‘solved’ the problem simply by eliminating the navbar! (more screen estate especially for the mapping element so no real loss…).
I still have a few issues with iOS but will persist and see what happens.