V7 odd error after update

I copied the F7 V7 css and js files to my app and the error shown in the screengrab below appears. Any ideas?
Screenshot 5

What browser & version are you using?

Same issue in Safari 15.5 and. Chrome 100.0

It works fine for me in Chrome 100. What you’re getting (you probably already know) is a replacement character Specials (Unicode block) - Wikipedia(often,data%20to%20a%20correct%20symbol.

Make sure in your index.html you have the following tag:
<meta charset="utf-8">

What IDE are you using to author your code? Is it running in a language other than English?

Already had that meta tag.
Developing the HTML in Nova (in English)

Same error with …-bundle.js and …bundle.min.js V7 but not with either V6 version.

I ran the UTF-8 conversion routine in Nova but no difference.

Does 7.0.1 give you any better results?

It is 7.01 that I am using…

Could you upload your local copy of framework7-bundle.min.js somewhere and link to it, so we can take a look at the code?

Both are here:


Thanks. When does the error occur? Is it when the app has first loaded, before any interaction? Or after a specific action has occured?

It occurs as the app is loading - just shows a blank page…

your file is corrupted (**** happens)
you need to redownload it

I downloaded both files more than once so not sure this will work…
thanks anyway

first line:

_WebResourceFrameName_WebResourceData_WebResourceMIMEType_eWebResourceTextEncodingName^WebResourceURLPO�@Æ<html><head></head><body><pre style="word-wrap: break-word; white-space: pre-wrap;">/**

last line:

//# sourceMappingURL=framework7-bundle.min.js.map</pre></body></html>_application/javascriptUUTF-8_;https://unpkg.com/[email protected]/framework7-bundle.min.js������������(���?���Q���g���Ö���î���ï�AI�Ab�Ah�������������

it’s clearly corrupted
delete those lines or redownload it
there is nothing else you can do

I was not able too match your errors with my copy.
Re-downloaded and same issue.

So, rather than keep following that path I copied the code from the unplug.com version, pasted it into my copy and it works fine now…

Bit lost as to the true cause but grateful that you put me on the right path!

Same issue in Safari 15.5 and. Chrome 100.0

Re-downloaded and same issue.